const regex = /^https?:\/{2}regex101\.com\/r\/([a-zA-Z0-9]{6})(?:\/(\d+)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/{2}regex101\\.com\\\/r\\\/([a-zA-Z0-9]{6})(?:\\\/(\\d+)?)', 'gm')
const str = `http://regex101.com/r/mH1fN5
https://regex101.com/r/fW0vZ2
https://regex101.com/r/wY0rM7/3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}