# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[0187]?|\+[87]?)[- .]?(?:(\([2-9]\d{2}\)|[2-9]\d{2})[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?)$"
test_str = ("+89031231232\n"
"92912312-32\n"
"+7929 123 12 32\n"
"+8 929 12-312-32\n"
"+8 929 123-12-32")
subst = "+7 (\\1) \\2\\3\\4 \\5\\6 \\7\\8"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.