use strict;
my $str = '+89031231232
92912312-32
+7929 123 12 32
+8 929 12-312-32
+8 929 123-12-32';
my $regex = qr/^(?:[0187]?|\+[87]?)[- .]?(?:(\([2-9]\d{2}\)|[2-9]\d{2})[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?)$/mp;
my $subst = '+7 (\\1) \\2\\3\\4 \\5\\6 \\7\\8';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";