const regex = /(^|\s)@([A-z]+)\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)@([A-z]+)\\b', 'gi')
const str = `@whatever
whatever
`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);