package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(^|\s)@([A-z]+)\b`)
var str = `@whatever
whatever
`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}