# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"( \(\d{4}_\d{2}_\d{2} \d{2}_\d{2}_\d{2} \w{3}\))+|\1.\w{3}\n"
test_str = ("\n"
"Acacia tree 2 (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"Acacia tree 2 (2015_12_03 14_18_17 UTC).jpg\n"
"JOURNEY TO ARABIA (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
"Acacia Tree 4 (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n\n\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\AFRICA THE MOTHER OF US ALL 3 (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\AFRICAN MAN + CROCODILE (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\AFRICAN MAN + CROCODILE (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\AFRICAN MAN + CROCODILE (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\African muslim with favorite slave (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\African muslim with favorite slave (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\African muslim with favorite slave (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\amagufwa ya bene Rwanda (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\amagufwa ya bene Rwanda (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\amagufwa ya bene Rwanda (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ama-Rank y' inyenzi (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ama-Rank y' inyenzi (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ama-Rank y' inyenzi (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Amenhotep_III (1) (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Amenhotep_III (1) (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Amenhotep_III (1) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Amenhotep_III (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Amenhotep_III (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Amenhotep_III (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\amenhotep3_head_03 (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\amenhotep3_head_03 (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\amenhotep3_head_03 (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\an Egyptian [Sudanese woman] (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\an Egyptian [Sudanese woman] (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\an Egyptian [Sudanese woman] (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\an Egyptian [Sudanese woman]2 (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\an Egyptian [Sudanese woman]2 (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\an Egyptian [Sudanese woman]2 (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Ancient Africa How Europeans have it wrong - Kevin MacDonald (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Ancient Africa How Europeans have it wrong - Kevin MacDonald (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Ancient Africa How Europeans have it wrong - Kevin MacDonald (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ancient African script (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ancient African script (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ancient African script (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Ancient African Scripts (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Ancient African Scripts (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Ancient African Scripts (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ancient African writings (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ancient African writings (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ancient African writings (2015_12_03 14_18_17 UTC).png\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ANCIENT HEBREWS DWELLINGS (2014_10_06 13_06_05 UTC) \n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Bamwe mu basigajwe inyuma n’amateka bo mu Mudugudu wa Bukamba - LEVITES (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Baobab (Adansonia digitata) and elephant, Tanzania (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
"D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Baobab (Adansonia digitata) and elephant, Tanzania (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.