#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "( \(\d{4}_\d{2}_\d{2} \d{2}_\d{2}_\d{2} \w{3}\))+|\1.\w{3}\n"
Local $sString = "" & @CRLF & _
"Acacia tree 2 (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"Acacia tree 2 (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"JOURNEY TO ARABIA (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"Acacia Tree 4 (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\AFRICA THE MOTHER OF US ALL 3 (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\AFRICAN MAN + CROCODILE (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\AFRICAN MAN + CROCODILE (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\AFRICAN MAN + CROCODILE (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\African muslim with favorite slave (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\African muslim with favorite slave (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\African muslim with favorite slave (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\amagufwa ya bene Rwanda (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\amagufwa ya bene Rwanda (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\amagufwa ya bene Rwanda (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\ama-Rank y' inyenzi (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\ama-Rank y' inyenzi (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\ama-Rank y' inyenzi (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Amenhotep_III (1) (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Amenhotep_III (1) (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Amenhotep_III (1) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Amenhotep_III (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Amenhotep_III (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Amenhotep_III (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\amenhotep3_head_03 (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\amenhotep3_head_03 (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\amenhotep3_head_03 (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\an Egyptian [Sudanese woman] (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\an Egyptian [Sudanese woman] (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\an Egyptian [Sudanese woman] (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\an Egyptian [Sudanese woman]2 (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\an Egyptian [Sudanese woman]2 (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\an Egyptian [Sudanese woman]2 (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Ancient Africa How Europeans have it wrong - Kevin MacDonald (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Ancient Africa How Europeans have it wrong - Kevin MacDonald (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Ancient Africa How Europeans have it wrong - Kevin MacDonald (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\ancient African script (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\ancient African script (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\ancient African script (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Ancient African Scripts (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Ancient African Scripts (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Ancient African Scripts (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\ancient African writings (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\ancient African writings (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\ancient African writings (2015_12_03 14_18_17 UTC).png" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\ANCIENT HEBREWS DWELLINGS (2014_10_06 13_06_05 UTC) " & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Bamwe mu basigajwe inyuma n’amateka bo mu Mudugudu wa Bukamba - LEVITES (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Baobab (Adansonia digitata) and elephant, Tanzania (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg" & @CRLF & _
"D:\Kmna\Desktop\FACE-PICTS\RAW MATERIALS\Baobab (Adansonia digitata) and elephant, Tanzania (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")