package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[([^,\]]+),([^,\]]+)\]`)
var str = ` this is the range of values [a1,b1] and [b1,a1]
this is the range of values (a1,b1) and [b2,a2]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}