using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^,\]]+),([^,\]]+)\]";
string input = @" this is the range of values [a1,b1] and [b1,a1]
this is the range of values (a1,b1) and [b2,a2]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}