re = /^(\b([0-3]{1}?[0-9]{1})(\/|-)([0-1]{1}?[0-9]{1})(\/|-)([1-2]{1}[0-9]{3})( |-| - )([1-9]{1}[0-9]{1}|[0-2]{1}[0-9]{1}):([0-5]{1}?[0-9]{1}):([0-5]{1}?[0-9]{1})\b)|(\b([0-3]{1}?[0-9]{1})(\/|-)([0-1]{1}?[0-9]{1})(\/|-)([1-2]{1}[0-9]{3})\b)$/mi
str = '13/08/2015 15:07:01
13/08/2015-15:07:01
13/08/2015 - 15:07:01
01/01/2015 - 11:00:00
01/01/2015 - 22:10:55
01/01/2015'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end