import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\b([0-3]{1}?[0-9]{1})(\\/|-)([0-1]{1}?[0-9]{1})(\\/|-)([1-2]{1}[0-9]{3})( |-| - )([1-9]{1}[0-9]{1}|[0-2]{1}[0-9]{1}):([0-5]{1}?[0-9]{1}):([0-5]{1}?[0-9]{1})\\b)|(\\b([0-3]{1}?[0-9]{1})(\\/|-)([0-1]{1}?[0-9]{1})(\\/|-)([1-2]{1}[0-9]{3})\\b)$";
final String string = "13/08/2015 15:07:01\n"
+ "13/08/2015-15:07:01\n"
+ "13/08/2015 - 15:07:01\n"
+ "01/01/2015 - 11:00:00\n"
+ "01/01/2015 - 22:10:55\n"
+ "01/01/2015";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}