re = /`(?P<class>\w+)>>(?P<method>(?:\w+):?(?:(?:(?:\w+):)+))`/
str = '`GHRequester>>blabla:blabl:`'
# Print the match result
str.match(re) do |match|
puts match.to_s
end