#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "`(?P<class>\w+)>>(?P<method>(?:\w+):?(?:(?:(?:\w+):)+))`"
Local $sString = "`GHRequester>>blabla:blabl:`"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")