re = /(?P<symbol>[0-9]?[A-Z]+)(?P<contract>[FGHJKMNQUVXZ]+\d{1,2}) (?P<yellow_key>(COMB )?Comdty)/m
str = 'VBYU4 Comdty'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end