package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<symbol>[0-9]?[A-Z]+)(?P<contract>[FGHJKMNQUVXZ]+\d{1,2}) (?P<yellow_key>(COMB )?Comdty)`)
var str = `VBYU4 Comdty`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}