re = /B(?<StartByte>[0-9])(?:.(?<StartBit>[0-7]))?(?:<<(?<LeftShift>[0-9]))?\|?/
str = 'B0<<8|B0|B1.6<<8
B0.7<<8
(B0.7-B0.0)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end