$re = '/(.+?|)(tir(a|o)?|dispar(a|o)?|lanz(a|o)?|mape(a|o)?|us(o|a)?)(.+?|)(sonda|planeta|burbuja|mater?)(.+?|)\?/m';
$str = 'Alguien tiene alguna imagen donde se vea donde tirar las sondas para escanear planetas?
tiro sondas?
lanzar sondas?
lanzo sonda?
mapear planetas?
uso las sondas?
disparan sondas?
usas las sondas?
usa las sondas?
usais las sondas?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);