using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?|)(tir(a|o)?|dispar(a|o)?|lanz(a|o)?|mape(a|o)?|us(o|a)?)(.+?|)(sonda|planeta|burbuja|mater?)(.+?|)\?";
string input = @"Alguien tiene alguna imagen donde se vea donde tirar las sondas para escanear planetas?
tiro sondas?
lanzar sondas?
lanzo sonda?
mapear planetas?
uso las sondas?
disparan sondas?
usas las sondas?
usa las sondas?
usais las sondas?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}