// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b((v.+)|(a|alpha.+)|(b|beta.+))?\s?(\d+\.)?(\d+\.)?(\*|\d+).+((a|alpha.+)|(b|beta.+))?").unwrap();
let string = "Version 1.2.3
Ver 6.5.3
V 9.1
V 2016-2-20
Version 19-03.1970
Ver6.5.3
V9.1
V2016-2-20
Version19-03.1970
version 1.2.3
ver 6.5.3
v 9.1
v 2016-2-20
version 19-03.1970
ver6.5.3
v9.1
v2016-2-20
version19-03.1970
6.5.3
9.1
2016-2-20
19-03.1970
/****************************
* Sample Header Comment
* Created by Jane Programmer
* 2016-05-01
*
* Version 00.09 Beta
*/
##############################
# Sample Comment Test 2
# Created by Joe Cool (Snoppy)
# 12/31/1979
#
# V8 (beta)
####
V8.45.32 beta
v78.14.01 Alpha
Alpha 781.54.1
Beta 12.07.79
a1.2.3
b4.5.6-99
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}