import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((v.+)|(a|alpha.+)|(b|beta.+))?\\s?(\\d+\\.)?(\\d+\\.)?(\\*|\\d+).+((a|alpha.+)|(b|beta.+))?";
final String string = "Version 1.2.3\n"
+ "Ver 6.5.3\n"
+ "V 9.1\n"
+ "V 2016-2-20\n"
+ "Version 19-03.1970\n\n"
+ "Ver6.5.3\n"
+ "V9.1\n"
+ "V2016-2-20\n"
+ "Version19-03.1970\n\n"
+ "version 1.2.3\n"
+ "ver 6.5.3\n"
+ "v 9.1\n"
+ "v 2016-2-20\n"
+ "version 19-03.1970\n\n"
+ "ver6.5.3\n"
+ "v9.1\n"
+ "v2016-2-20\n"
+ "version19-03.1970\n\n"
+ "6.5.3\n"
+ "9.1\n"
+ "2016-2-20\n"
+ "19-03.1970\n\n"
+ "/****************************\n"
+ "* Sample Header Comment\n"
+ "* Created by Jane Programmer\n"
+ "* 2016-05-01\n"
+ "*\n"
+ "* Version 00.09 Beta\n"
+ "*/\n\n\n"
+ "##############################\n"
+ "# Sample Comment Test 2\n"
+ "# Created by Joe Cool (Snoppy)\n"
+ "# 12/31/1979\n"
+ "# \n"
+ "# V8 (beta)\n"
+ "####\n\n\n"
+ "V8.45.32 beta\n"
+ "v78.14.01 Alpha\n"
+ "Alpha 781.54.1\n\n"
+ "Beta 12.07.79\n\n"
+ "a1.2.3\n"
+ "b4.5.6-99\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}