re = /^\/?[\w-\/]+$/m
str = '/home/user/Documents
/home/user/Documents-list_-/
home/user/Documents-list_-/
home/
space /home/user/Documents/file.name
/home/user/Documents/foo.log
/foo.bar
/folder
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end