package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/?[\w-/]+$`)
var str = `/home/user/Documents
/home/user/Documents-list_-/
home/user/Documents-list_-/
home/
space /home/user/Documents/file.name
/home/user/Documents/foo.log
/foo.bar
/folder
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}