$re = '/special=[a-zA-Z0-9]{2,}/';
$str = 'https://site.com/page/offer?special=523&go=1
https://site.com/666/redirect/error.html?special=ok
https://site.com/rd/page/error.html?special
https://site.com/redirect/pages/error?special=1
https://site.com/special/12/error?go=ok';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);