using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"special=[a-zA-Z0-9]{2,}";
string input = @"https://site.com/page/offer?special=523&go=1
https://site.com/666/redirect/error.html?special=ok
https://site.com/rd/page/error.html?special
https://site.com/redirect/pages/error?special=1
https://site.com/special/12/error?go=ok";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}