# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^
(?P<show>[a-zA-Z1-9\.\-]+[^\.])
\.[Ss]?(?P<season>\d{1,2})[EeXx](?P<episode>\d{1,2})
(\.(?P<title>[a-zA-Z1-9\.]+[^\.]))?
\.(?P<resolution>\d{3,4}p)
\.(?P<quality>[a-zA-Z\-]{1,6})
\.(?P<codec>[a-zA-Z0-9\.]+\d)
([\.\-](?P<team>.+))?
$
"""
test_str = ("Person.of.Interest.S05E13.720p.HDTV.X264-DIMENSION\n"
"The.Big.Bang.Theory.S09E21.720p.HDTV.X264-DIMENSION[ettv]\n"
"Homeland.S05E11.Our.Man.in.Damascus.720p.WEB-DL.DD5.1.H264-NTb[rarbg]\n"
"limitless.s01e01.pilot.720p.webrip.hevc.x265.rmteam\n"
"vikings.s04e01.a.good.treason.720p.web.dl.hevc.x265.rmteam\n"
"Brooklyn.Nine-Nine.S03E23.720p.WEBRip.x264\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.