use strict;
my $str = 'Person.of.Interest.S05E13.720p.HDTV.X264-DIMENSION
The.Big.Bang.Theory.S09E21.720p.HDTV.X264-DIMENSION[ettv]
Homeland.S05E11.Our.Man.in.Damascus.720p.WEB-DL.DD5.1.H264-NTb[rarbg]
limitless.s01e01.pilot.720p.webrip.hevc.x265.rmteam
vikings.s04e01.a.good.treason.720p.web.dl.hevc.x265.rmteam
Brooklyn.Nine-Nine.S03E23.720p.WEBRip.x264
';
my $regex = qr/^
(?P<show>[a-zA-Z1-9\.\-]+[^\.])
\.[Ss]?(?P<season>\d{1,2})[EeXx](?P<episode>\d{1,2})
(\.(?P<title>[a-zA-Z1-9\.]+[^\.]))?
\.(?P<resolution>\d{3,4}p)
\.(?P<quality>[a-zA-Z\-]{1,6})
\.(?P<codec>[a-zA-Z0-9\.]+\d)
([\.\-](?P<team>.+))?
$/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}