re = /\[\/?(embed|slider|---).*\]/
str = '[embed]
[---]
[sdfsfs]
[slider dsfsdf=fsdfs]
sdfsdfsf
[/slider]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end