package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\/?(embed|slider|---).*\]`)
var str = `[embed]
[---]
[sdfsfs]
[slider dsfsdf=fsdfs]
sdfsdfsf
[/slider]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}