$re = '/^(.?)(.?)(.?)(.?)(.?).?\5\4\3\2\1$/';
$str = '1221';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);