const regex = /^(.?)(.?)(.?)(.?)(.?).?\5\4\3\2\1$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.?)(.?)(.?)(.?)(.?).?\\5\\4\\3\\2\\1$', '')
const str = `1221`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}