import Foundation
let pattern = #"(?P<req_ip>^[\d\.]+)\s+(?P<req_identity>.+?)\s+(?P<req_user>.+?)\s+\[(?P<req_date>.+?)\]\s+"(?P<req_method>.+?)\s+(?P<req_path>.+?)\s+(?P<req_protocoll>.+?)"\s+(?P<req_code>.+?)\s+(?P<req_size>.+?)\s+"(?P<req_referer>.+?)"\s+"(?P<req_device>.+?|)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
165.72.105.195 - - [11/May/2021:14:14:14 +0000] "POST /us/en/registration.html HTTP/1.1" 500 1676 "https://my.domain.com/us/en/registration.html" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.44 Safari/537.36 OPR/69.0.3686.7 (Edition beta)"
199.40.163.0 - - [25/May/2021:10:37:14 +0000] "GET /etc/clientlibs/dhl/global/public/img/my-plus.svg HTTP/1.1" 200 1452 "https://my.dmain.com/cn/zh/help-and-support.html" ""
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)