$re = '/^/(\?.*)?$/';
$str = 'https://';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;