use strict;
my $str = 'https://';
my $regex = qr/^/(\?.*)?$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";