$re = '/http:\/\/(www)?[a-zA-Z0-9]+\.(com|ru|net)\/(\w+)*/';
$str = 'http://google.com/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);