const regex = /http:\/\/(www)?[a-zA-Z0-9]+\.(com|ru|net)\/(\w+)*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/(www)?[a-zA-Z0-9]+\\.(com|ru|net)\\\/(\\w+)*', '')
const str = `http://google.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}