package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^127\.\d{1,3}\.\d{1,3}\.\d{1,3}(\:\d+)?$`)
var str = `127.1.1.1:4000
127.12.12.12
127.0.0.2:599595
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}