using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^127\.\d{1,3}\.\d{1,3}\.\d{1,3}(\:\d+)?$";
string input = @"127.1.1.1:4000
127.12.12.12
127.0.0.2:599595
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}