// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:4[0-9]{12}(?:[0-9]{3})?|5[1-5][0-9]{14}|3[47][0-9]{13}|3(?:0[0-5]|[68][0-9])[0-9]{11}|6(?:011|5[0-9]{2})[0-9]{12}|(?:2131|1800|35\d{3})\d{11})$").unwrap();
let string = "# American Express
378282246310005
371449635398431
# American Express Corporate
378734493671000
# Diners Club
30569309025904
38520000023237
# Discover
6011111111111117
6011000990139424
# JCB
3530111333300000
3566002020360505
# MasterCard
5555555555554444
5105105105105100
# Visa
4111111111111111
4012888888881881
4222222222222
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}