import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:4[0-9]{12}(?:[0-9]{3})?|5[1-5][0-9]{14}|3[47][0-9]{13}|3(?:0[0-5]|[68][0-9])[0-9]{11}|6(?:011|5[0-9]{2})[0-9]{12}|(?:2131|1800|35\\d{3})\\d{11})$";
final String string = "# American Express\n"
+ "378282246310005\n"
+ "371449635398431\n"
+ "# American Express Corporate\n"
+ "378734493671000\n"
+ "# Diners Club\n"
+ "30569309025904\n"
+ "38520000023237\n"
+ "# Discover\n"
+ "6011111111111117\n"
+ "6011000990139424\n"
+ "# JCB\n"
+ "3530111333300000\n"
+ "3566002020360505\n"
+ "# MasterCard\n"
+ "5555555555554444\n"
+ "5105105105105100\n"
+ "# Visa\n"
+ "4111111111111111\n"
+ "4012888888881881\n"
+ "4222222222222\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}