import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s(L.?T.?D.?A.?|E.?I.?R.?L.?|S.?P.?A.?)|(LI?MI?T[DA]{0,3})|(S[\\.\\s]{0,2}?A\\.?)$";
final String string = "CONSTRUCTORA CORACEROS LIMITADA\n"
+ "SERVICIOS EXTERNOS SARE LTDA\n"
+ "SOCIEDAD COMERCIAL DE REPRESENTACIONES LIMITADA\n"
+ "NGS S.A.\n"
+ "INTERNATIONAL SERVICE LIMITADA\n"
+ "DARTEL TALCA LIMITADA\n"
+ "EUROMERCAD S A\n"
+ "CARGO ENTREGA S A\n"
+ "DE LA FUENTE Y CARPANETTI LIMITADA\n"
+ "INGELAN CONSULTORES LIMITADA\n"
+ "CIA INMOBILIARIA Y DE INVERSIONES TRICELTA LIMITADA\n"
+ "CHILENA DE COMPUTACION LIMITADA\n"
+ "ASESORIAS E INVERSIONES RPV LIMITADA\n"
+ "SOC AGRICOLA Y GANADERA EL MEMBRILLAR LIMITADA\n"
+ "R Y C CARGO LTDA\n"
+ "TEJIDOS TRENZATEX LIMITADA\n"
+ "GENIAL DISENO Y PUBLICIDAD LIMITADA\n"
+ "ACME ANALYTICAL LABORATORIES S A\n"
+ "SOC DE TRANSPORTES VALIJA Y CARGAS SERVIVAL LIMITADA\n"
+ "COMERCIAL E INDUSTRIAL SAN ANGEL LIMITAD\n"
+ "ARKADIA MUEBLES Y DECORACIONES LTDA\n"
+ "IMPORTADORA EXPORTADORA YARDAS LIMITADA\n"
+ "REPDEVAL EQUIPOS Y COMPANIA LIMITADA\n"
+ "AGENCIA DE ADUANAS JORGE E. CELIS CORNEJO CIA LTDA\n"
+ "PINTO GLAVICH INGENIERIA Y CONSTRUCCION S A\n"
+ "PRODUCTOS MITRE LIMITADA\n"
+ "IMPORTADORA Y COMERCIAL ALTEA LTDA\n"
+ "COMERCIAL ICOM SPA\n"
+ "VINA CASABLANCA S.A.\n"
+ "LATCAM PAGOS INTERNACIONALES S.A.\n"
+ "SERVICIOS DE MARKETING DIRECTO Y MERCHANDISING LIMITADA\n"
+ "MONTAJES OROPESA LIMITADA\n"
+ "AMENABAR Y ASOCIADOS TALLERES GRAFICOS S.A.\n"
+ "SOCIEDAD SPORT TRADE LIMITADA\n"
+ "VINA PIRAZZOLI LIMITADA\n"
+ "OPTICA NUEVA VISION LIMITADA\n"
+ "B & S SOLUCIONES COMPUTACIONALES LIMITADA\n"
+ "SOC COMERCIAL PROLABI LIMITADA\n"
+ "CENTRO DE COMUNICACIONES COPIAPO LIMITADA\n"
+ "TECNOAYSEN LTDA\n"
+ "COMERCIO INTERNAC REPRESENT E INV SECTRADE LIMITADA\n"
+ "SOC GASTRONOMICA CASABLANCA LIMITADA\n"
+ "SOC COMERC TRADE MARK LIMITADA\n"
+ "SOC COMERCIAL E INMOBILIARIA PLASTOCK LIMITADA\n"
+ "SOC PUBLICITARIA MORENO Y COMPANIA LIMITADA\n"
+ "N PRODUCCIONES LIMITADA\n"
+ "TECNOLOGIA Y SERVICIOS EN COMPRESORES LIMITADA\n"
+ "PRODUCTOS Y SERVICIOS COMPUTACIONALES LIMITADA\n"
+ "AERO ANDINA S A\n"
+ "COMERCIALIZADORA BANDELSUR LIMITADA\n"
+ "GLOVOX PRODUCCIONES LIMITADA\n"
+ "COMERCIAL LORENA GONZALEZ RAMOS E.I.R.L.\n"
+ "HOSPITAL & DIAGNOSTICS SUPPLIES LIMITADA\n"
+ "APOYO EXPRESS SERVICIOS LIMITADA\n"
+ "AGRICOLA LAS MERCEDES DEL LIMARI LIMITADA\n"
+ "ALIMENTOS DEL NORTE LIMITADA\n"
+ "IKONS ATN INVERSIONES LIMITADA\n"
+ "JULIO Y NIXON LIMITADA\n"
+ "SOC AGRICOLA Y COMERCIAL JERUSALEM LIMITADA\n"
+ "IMAGEN Y DISENO LIMITADA\n"
+ "XPERIENCE CONSULTORIA Y SERVICIOS COMPUTACIONALES LIMTADA\n"
+ "SERVICIOS PUBLICITARIOS CANAL DIRECTO LIMITADA";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}