#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\s(L.?T.?D.?A.?|E.?I.?R.?L.?|S.?P.?A.?)|(LI?MI?T[DA]{0,3})|(S[\.\s]{0,2}?A\.?)$"
Local $sString = "CONSTRUCTORA CORACEROS LIMITADA" & @CRLF & _
"SERVICIOS EXTERNOS SARE LTDA" & @CRLF & _
"SOCIEDAD COMERCIAL DE REPRESENTACIONES LIMITADA" & @CRLF & _
"NGS S.A." & @CRLF & _
"INTERNATIONAL SERVICE LIMITADA" & @CRLF & _
"DARTEL TALCA LIMITADA" & @CRLF & _
"EUROMERCAD S A" & @CRLF & _
"CARGO ENTREGA S A" & @CRLF & _
"DE LA FUENTE Y CARPANETTI LIMITADA" & @CRLF & _
"INGELAN CONSULTORES LIMITADA" & @CRLF & _
"CIA INMOBILIARIA Y DE INVERSIONES TRICELTA LIMITADA" & @CRLF & _
"CHILENA DE COMPUTACION LIMITADA" & @CRLF & _
"ASESORIAS E INVERSIONES RPV LIMITADA" & @CRLF & _
"SOC AGRICOLA Y GANADERA EL MEMBRILLAR LIMITADA" & @CRLF & _
"R Y C CARGO LTDA" & @CRLF & _
"TEJIDOS TRENZATEX LIMITADA" & @CRLF & _
"GENIAL DISENO Y PUBLICIDAD LIMITADA" & @CRLF & _
"ACME ANALYTICAL LABORATORIES S A" & @CRLF & _
"SOC DE TRANSPORTES VALIJA Y CARGAS SERVIVAL LIMITADA" & @CRLF & _
"COMERCIAL E INDUSTRIAL SAN ANGEL LIMITAD" & @CRLF & _
"ARKADIA MUEBLES Y DECORACIONES LTDA" & @CRLF & _
"IMPORTADORA EXPORTADORA YARDAS LIMITADA" & @CRLF & _
"REPDEVAL EQUIPOS Y COMPANIA LIMITADA" & @CRLF & _
"AGENCIA DE ADUANAS JORGE E. CELIS CORNEJO CIA LTDA" & @CRLF & _
"PINTO GLAVICH INGENIERIA Y CONSTRUCCION S A" & @CRLF & _
"PRODUCTOS MITRE LIMITADA" & @CRLF & _
"IMPORTADORA Y COMERCIAL ALTEA LTDA" & @CRLF & _
"COMERCIAL ICOM SPA" & @CRLF & _
"VINA CASABLANCA S.A." & @CRLF & _
"LATCAM PAGOS INTERNACIONALES S.A." & @CRLF & _
"SERVICIOS DE MARKETING DIRECTO Y MERCHANDISING LIMITADA" & @CRLF & _
"MONTAJES OROPESA LIMITADA" & @CRLF & _
"AMENABAR Y ASOCIADOS TALLERES GRAFICOS S.A." & @CRLF & _
"SOCIEDAD SPORT TRADE LIMITADA" & @CRLF & _
"VINA PIRAZZOLI LIMITADA" & @CRLF & _
"OPTICA NUEVA VISION LIMITADA" & @CRLF & _
"B & S SOLUCIONES COMPUTACIONALES LIMITADA" & @CRLF & _
"SOC COMERCIAL PROLABI LIMITADA" & @CRLF & _
"CENTRO DE COMUNICACIONES COPIAPO LIMITADA" & @CRLF & _
"TECNOAYSEN LTDA" & @CRLF & _
"COMERCIO INTERNAC REPRESENT E INV SECTRADE LIMITADA" & @CRLF & _
"SOC GASTRONOMICA CASABLANCA LIMITADA" & @CRLF & _
"SOC COMERC TRADE MARK LIMITADA" & @CRLF & _
"SOC COMERCIAL E INMOBILIARIA PLASTOCK LIMITADA" & @CRLF & _
"SOC PUBLICITARIA MORENO Y COMPANIA LIMITADA" & @CRLF & _
"N PRODUCCIONES LIMITADA" & @CRLF & _
"TECNOLOGIA Y SERVICIOS EN COMPRESORES LIMITADA" & @CRLF & _
"PRODUCTOS Y SERVICIOS COMPUTACIONALES LIMITADA" & @CRLF & _
"AERO ANDINA S A" & @CRLF & _
"COMERCIALIZADORA BANDELSUR LIMITADA" & @CRLF & _
"GLOVOX PRODUCCIONES LIMITADA" & @CRLF & _
"COMERCIAL LORENA GONZALEZ RAMOS E.I.R.L." & @CRLF & _
"HOSPITAL & DIAGNOSTICS SUPPLIES LIMITADA" & @CRLF & _
"APOYO EXPRESS SERVICIOS LIMITADA" & @CRLF & _
"AGRICOLA LAS MERCEDES DEL LIMARI LIMITADA" & @CRLF & _
"ALIMENTOS DEL NORTE LIMITADA" & @CRLF & _
"IKONS ATN INVERSIONES LIMITADA" & @CRLF & _
"JULIO Y NIXON LIMITADA" & @CRLF & _
"SOC AGRICOLA Y COMERCIAL JERUSALEM LIMITADA" & @CRLF & _
"IMAGEN Y DISENO LIMITADA" & @CRLF & _
"XPERIENCE CONSULTORIA Y SERVICIOS COMPUTACIONALES LIMTADA" & @CRLF & _
"SERVICIOS PUBLICITARIOS CANAL DIRECTO LIMITADA"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)