re = /(.)\1{2}/i
str = 'Can you ppplease help me fix thhhis?
2342343333332352523e312422222
!!!32&&&%^**())))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end