$re = '/(.)\1{2}/i';
$str = 'Can you ppplease help me fix thhhis?
2342343333332352523e312422222
!!!32&&&%^**())))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);