$re = '/([^0+][1-9]{2})\d{1,13}/';
$str = '085296887000
6285296887000
+6285296887000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);