$re = '/^(\+){0,1}(254){0,1}(70|71|72|79)(\d{7})|(254){0,3}(740|741|742|743|745|746|748|757|758|759|768|769|110|111)(\d{6})$/m';
$str = 'VALID NUMBERS
254715228228
254722228228
254729228228
254745229228
254769229228
254110229228
254111229228
INVALID NUMBERS
254730229228
254744229228
254747229228
254760229228
254100229228
Sources: https://ca.go.ke/wp-content/uploads/2020/01/Telecommunication-Numbering-Plan-for-Kenya-Feb-2020-compressed.pdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);