use strict;
my $str = 'VALID NUMBERS
254715228228
254722228228
254729228228
254745229228
254769229228
254110229228
254111229228
INVALID NUMBERS
254730229228
254744229228
254747229228
254760229228
254100229228
Sources: https://ca.go.ke/wp-content/uploads/2020/01/Telecommunication-Numbering-Plan-for-Kenya-Feb-2020-compressed.pdf
';
my $regex = qr/^(\+){0,1}(254){0,1}(70|71|72|79)(\d{7})|(254){0,3}(740|741|742|743|745|746|748|757|758|759|768|769|110|111)(\d{6})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}