re = /^(?P<WFF>(?P<L>~*(?>[A-Z\^!]|\(\g<WFF>\)))(?(?=\$)\$\g<L>|(?:(?P<O>[\%&|])(?:\g<L>\k<O>)*\g<L>)?))$/x
str = 'P&(Q$(R|S))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end