$re = '/^(([[a-zA-Z\p{L}\.\-\']{1,30})(\s))(([a-zA-Z\p{L}\.\-\']{1,30})(\s))?([[a-zA-Z\p{L}\.\-\']{1,30})(\s)?(\([a-zA-Z\p{L}\.\-\'\s]{1,50}\))?$/m';
$str = 'Robert Alvarez
Yvonne Andersen
Bob Anderson (director)
Mike B. Anderson
Stephen Anderson (artist)
Joel Zwick
Terry Zwigoff
Andrzej Żuławski
Xawery Żuławski
Harald Zwart
Ezz El-Dine Zulficar (potate)
Irvin S. Yeaworth Jr.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);