use strict;
my $str = 'Robert Alvarez
Yvonne Andersen
Bob Anderson (director)
Mike B. Anderson
Stephen Anderson (artist)
Joel Zwick
Terry Zwigoff
Andrzej Żuławski
Xawery Żuławski
Harald Zwart
Ezz El-Dine Zulficar (potate)
Irvin S. Yeaworth Jr.
';
my $regex = qr/^(([[a-zA-Z\p{L}\.\-']{1,30})(\s))(([a-zA-Z\p{L}\.\-']{1,30})(\s))?([[a-zA-Z\p{L}\.\-']{1,30})(\s)?(\([a-zA-Z\p{L}\.\-'\s]{1,50}\))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}