$re = '/\d*[0]{5}$/';
$str = 'validate 100k * x';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);